Problem:
There have been a few recent reports of devices being adversely affected in combination with IntraVUE being used at the time of the incidents. This is limited to the scenario where the IntraVUE host is configured as the top parent, and there are sensitive devices in the local network.
Cause:
We have determined that there is no issue with the IntraVUE software itself, but rather with the operating system on which IntraVUE is installed. We discovered that Microsoft made some changes to the way ARP packets are handled by the Windows’ OS starting with Windows 7. This impacts any software that cause ARPs such as ping scanners, network monitors, and PCs \ VMs.
Before Windows 7 if an initial ARP was not answered in .5 seconds a first retry ARP was issued. If that ARP was not answered in another .5 seconds a second retry ARP was issued. These retries maintained the original timing of ARPs on the network.
Starting with Windows 7 at .5 second intervals all ‘retry’ ARPs that have not been answered are reissued in a burst. The spacing in the bursts is about 40 microseconds apart (wire speed) and does not conform to the Speed settings of IntraVUE.
Certain old devices within industrial networks cannot handle many ARP requests in a short time frame, which may cause them to reset. Examples of devices that can be affected include old PLCs (e.g. PLC5) and some I/O devices (e.g. bridges & gateways that communicate with old PLCs).
Resolution:
In version 3.1 of the software we have implemented a temporary fix which slows the discovery and mitigates the problem. In order to revert the fix and return to the standard speeds, first confirm that one of the following is true for your network:
1) The host computer IP address is outside of the network with susceptible devices and use a Layer 3 switch \ router as the top parent for the network so ARP packets go through the Layer 3
2) An IntraVUE appliance is used as an Agent between the host computer and the network
3) An IntraVUE Appliance (Linux VM) or Microsoft Windows XP operating system is used as the IntraVUE host
After confirming the above modify the following line in the …\intravue\autoip\ivserver.properties file by putting a ‘#’ symbol at the start of the following line at the bottom of the file.
unknown.devices.quota.max=2
Any customer having issues is encouraged to contact IntraVUE Tech Support (techsupport@panduit.com) for assistance in optimizing their system.
We are working with Microsoft to address this issue within their operating system and expect they should also be addressing this issue.